Mods / Necessaries Fix

Draft
Set to published to be listed. A draft mod is still visible to everyone via direct link
Category: #Crafting #QoL #Technology #Weapons
Author: Maamessu
Side: Both
Created: Nov 21st 2022 at 11:59 PM
Last modified: Nov 22nd 2022 at 12:03 AM
Downloads: 1529
Follow Unfollow 29

Latest file for v1.17.9:
Necessaries_v1.1.3-Fix.zip 1-click install


This is the wonderful Necessaries mod by ZigTheHedge.

This is just a quick little fix which allows the falx to be sharpened on the grindstone, like the longblade in previous game versions.

Nothing else has been modified, and hopefully the original author gets a chance to update the mod properly in the near future.

I have marked this as compatible with 1.17.9, as I haven't found any other issues with it.

Please enjoy, and let me know if anything explodes, though I can't promise fixes.

Version For Game version Downloads Release date Changelog Download 1-click mod install*
v1.1.3-rc.1 1529 Nov 22nd 2022 at 12:03 AM Show Necessaries_v1.1.3-Fix.zip Install now

6 Comments (oldest first | newest first)

💬 Falco, Feb 12th 2023 at 12:35 AM

would be nice if this could be a patch instead of a full replacement.

That way the original author still gets the downloads, and if he ever updates one only needs to delete the patch. If he ever updates without patching this particular issue himself, the patch would stay valid and you get all the new features without doing anything else.

If you have it a separate copy you would have to painfully merge the two versions by hand.

💬 MaamessuAuthor, Nov 22nd 2022 at 8:44 PM

Yanazake, PeterSanderson,

At the moment it is a seamless substitue, replacing the original mod. Nothing else is affected, so when switching it out, your grindstones, branch cutters, etc, won't disappear.

I couldn't quite get overwriting the original file to work properly. It kept fighting me. 😓

💬 AzuliBluespots, Nov 22nd 2022 at 7:40 PM

PeterSanderson

probably alongside.
Thanks for this!

💬 PeterSanderson, Nov 22nd 2022 at 6:53 PM

Do we substitute this file or add it alongside Necessaries?

💬 MaamessuAuthor, Nov 22nd 2022 at 2:31 AM

Runehawk - Mmhm. When the longblade was replaced by the falx in the 1.17 update, the files were changed. Necessaries, even in the version marked for 1.17.1, is still looking for the longblade file, instead of the new one. This quick fix just points the mod in the right direction. 😀

💬 RuneScholar, Nov 22nd 2022 at 1:59 AM

Wait, are you otherwise unable to sharpen a falx with the grindstone? Have I just never tried it?

(edit comment delete)